PHP is one of the most widely used server-side programming languages. It is exceptionally popular because it is free software, which you can use to set up interactive sites such as social networking sites, online shops or e-learning websites instead of static HTML websites. A PHP module must be available on the server where a PHP-powered site is hosted so that its PHP code can be ‘decoded’. Since there aren’t any license taxes for such a module and the language itself offers countless possibilities for the Internet applications that you create, there’re 100s of millions of PHP websites. Also, there’re a multitude of open-source PHP-based scripts, which you can use for your sites without having to possess any coding capabilities. As there are different PHP versions, you must confirm whether the very same version that you used whilst developing your website is enabled on the web server too.

PHP 4 and PHP 5 Support in Shared Website Hosting

In case you get a shared website hosting plan from us, you won’t ever have to speculate over whether or not your sites are compatible with the web hosting platform, since multiple versions of PHP are activated on our servers for your convenience’s sake. The Hepsia Control Panel will permit you to choose PHP 4, 5.2, 5.3, 5.4 or 5.5 with only one click of the mouse and in case you want to change the version, the update will take effect instantly. In this way, several years of work on sites built with an older PHP version won’t be lost. Our web hosting platform will even allow you to use a different version of PHP for each domain name hosted in your account, which goes to say that you can use newer and older scripts at the same time. Most hosting companies on the marketplace offer one, sometimes two versions of PHP. Unlike them, we are convinced that you should be the one to choose the version that your very own websites will be using.

PHP 4 and PHP 5 Support in Semi-dedicated Servers

It’s our strong opinion that several years spent developing a website should not be in vain, which goes to say that if you buy a semi-dedicated server from us, you will be able to run any script, no matter if it’s new or old. In stark contrast to lots of web hosting companies, we support several different versions of PHP on our innovative cloud web hosting platform – 4, 5.2, 5.3, 5.4 and 5.5. You will not only be able to activate the required version through your Hepsia Control Panel, but you will also have the possibility to choose a different PHP version for each individual website. The latter can be done merely by putting an .htaccess file into the given site’s root folder. You can change the current version not only for a single website, but also for the entire account and the change will be applied in just several minutes. With our hosting services, you can rest assured that you won’t ever chance upon any website compatibility impediments.